How To Solve The Errorthe Ecm Is Not Supportedfor 2019c Cat Caterpillar Et Diagnostic Adapter Iii

You are here:
Estimated reading time: < 1 min

If you use the CAT Caterpillar ET Diagnostic Adapter III of the 2019C version of the software to test some older CAT cars, the following prompt appears:

This ECU is not supported.Please ensure that the latest version of the service tool is installed.and that the current subscription allows serviceing of this ECU.

It may be that the 2019C version of the software does not support this model. Please use the 2015A version of the software.

In our CAT Caterpillar ET Diagnostic Adapter III equipment, we will configure both 2015A and 2019C versions of the software. New models can use the 2019C software, and older models may need to use the 2015A software.

Was this article helpful?
Dislike 0
Views: 5
Previous: How To Use Cat Et Software